Как преобразовать текст в дату и наоборот в Excel?

Иногда возникает необходимость преобразования даты в текстовый формат и наоборот, для более удобного представления или анализа данных. В этой статье расскажем, как это сделать, используя разные функции Excel.

Оглавление

Преобразование с помощью форматирования ячейки

Форматирование подходит, если вы работаете с отдельной или несколькими ячейками и хотите изменить их формат для удобства чтения.

Преобразование даты в текст

Выберите категорию “Число”. В списке категорий на левой стороне окна выберите “Текстовый”
Преобразование даты в текст
При первичном вводе даты, Excel автоматически преобразует её в числовой формат, если необходимо представить данные в текстовом формате, можно воспользоваться форматированием ячейки:

1. Выберите ячейку с датой, которую нужно преобразовать в текст;
2. Нажмите правой кнопкой мыши на выбранной ячейке и выберите “Формат ячеек…” из меню контекста;
3. Выберите категорию “Число”. В списке категорий на левой стороне окна выберите “Текстовый”;
4. Нажмите кнопку “ОК”, чтобы закрыть диалоговое окно и применить форматирование.

Преобразование текста в дату

Выберите категорию “Число”. В списке категорий на левой стороне окна выберите “Дата”
Преобразование текста в дату
При импорте данных, иногда, Excel автоматически преобразует даты в текстовый формат. Воспользуйтесь форматированием ячейки, чтобы преобразовать текст в дату:

1. Выберите ячейку с текстом, которую нужно преобразовать в дату;
2. Нажмите правой кнопкой мыши на выбранной ячейке и выберите “Формат ячеек…” из меню контекста;
3. Выберите категорию “Число”. В списке категорий на левой стороне окна выберите “Дата”.
4. Нажмите кнопку “ОК”, чтобы закрыть диалоговое окно и применить форматирование.

Функция ТЕКСТ (TEXT)

Если нужно вставить дату определенного формата в текст, но без каких-то дополнительных действий, то функция ТЕКСТ (TEXT) хороший способ. Для этого достаточно использовать простую формулу:
=ТЕКСТ(Значение; "Формат даты")
Значение – это может быть просто дата, ссылка на ячейку с датой, или результат формулы.

Формат даты – вид, в котором нужно показать нашу дату. Формат должен быть указан в двойных кавычках и состоит из 4 составляющих: день, месяц, год и разделитель.

Чтобы начать применять функцию ТЕКСТ (TEXT), рассмотрим какие форматы и разделители бывают.

Форматы дат и разделители

Разделители и форматы дат можно комбинировать. Благодаря этому формат отображения достаточно гибко настраивается, например, вы сможете заполнить ячейки данными вида «25 фев, 2024 года».

Формат дня

Д — день отображается без нуля, т.е. 2 будет отображаться как 2, а 25 как 25;
ДД — день отображается с нулем, т.е. 2 будет 02, а 25 как 25;
ДДД — день недели отображается сокращенно, т.е. «Воскресенье» будет «Вс»;
ДДДД — день недели отображается полностью, т.е. «Воскресенье» будет «Воскресенье».

Формат месяца

М — месяц отображается без нуля, т.е. 2 будет отображаться как 2, а 11 как 11;
ММ — месяц отображается с нулем, т.е. 2 будет 02, а 11 как 11;
МММ — месяц отображается сокращенно, т.е. «Февраль» будет «фев»;
ММММ — месяц отображается полностью, т.е. «Февраль» будет «Февраль».

Формат года

ГГ — год отображается как 2 цифры, т.е. 2024 будет 24;
ГГГГ — год отображается полностью, т.е. 2024 будет 2024.

Разделители

«/» — отображается как 25/02/2024;
«-» — отображается как 25-02-2024;
«,» — отображается как 25,02,2024;
« » — отображается как 25 02 2024.

Переводим дату в текстовый формат

funkciya-tekst
Применение функции ТЕКСТ в Excel
Вводим в ячейку формулу, например, если дата находится в ячейке A1 и мы хотим привести ее к формату “ДД ММММ ГГГГ”, то в ячейке B1 вводим:
=ТЕКСТ(A1;"ДД ММММ ГГГГ")

Функция ТЕКСТ (TEXT) в комбинации с текстом

funkciya-tekst-v-kombinacii-s-tekstom (1)
Применение функции ТЕКСТ вместе с текстом в Excel
Функция ТЕКСТ (TEXT) отлично подойдет, если вы хотите вставить дату в какое-то определенное место текста и сразу преобразовать в текстовый формат.

Вводим в ячейку формулу, например, если дата находится в ячейке A2 и мы хотим вставить ее в середину текста “Ваш текст 26 Февраль 2024”, то в ячейке B2 вводим:
="Ваш текст "&ТЕКСТ(A2;"ДД ММММ ГГГГ")

Заключение

В этой статье, мы рассмотрели несколько способов преобразования даты в текстовый формат в Excel. Это может быть достигнуто как с помощью функций, так и с использованием форматирования ячеек. Важно помнить, что преобразование даты в текст обычно подразумевает потерю возможности автоматического вычисления и сравнения дат. Поэтому, прежде чем применять эти методы, следует убедиться, что форматирование не окажется проблемой для выполнения вашей задачи.

Если вы хотите прибрести полезные навыки для аналитики, воспользуйтесь каталогом онлайн-курсов по Excel.
Первые результаты — через неделю
Excel + «Google Таблицы» с нуля до PRO